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IndexAssistant for Microsoft Word 
IndexAssistant is software that tremendously improves Microsoft Word’s native indexing functions. Use its 
intelligent and powerful interface to help you view, maintain and apply a consistent set of index entries; keep track 
of the structure of your index as you build it; mark ranges of pages with one click; consolidate scattered single page 
index entries into ranges with one click; navigate and edit index entries in your document; and maintain cross 
references. A tremendous time and organizational saving over Word’s own interface when it comes time to index a 
manuscript. 
 
With the help of IndexAssistant, authors can use a fast index turnaround strategy.  Construct, check and proof your 
index in your Word document—before you receive your galleys.  When you receive your galleys, insert page breaks 
in your Word document so that its pagination matches that of your galleys.  Then have Word regenerate your index.  
Your turnaround time can be as little as one day, from your publisher’s point of view.     
 
With the help of IndexAssistant, professional indexers who do embedded indexing in Word can realize immense 
gains in speed and ease of use.  
 
IndexAssistant is shareware.  It costs $10 and requires Word 97 or higher.  If you intend to use IndexAssistant on an 
ongoing basis, purchase the full version through the website at http://jambient.com/indexassistant/.  

Screenshots 
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IndexAssistant working with Word: 
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Features of IndexAssistant: 
 
IndexAssistant maintains an alphabetized list of all index entries in your document. IndexAssistant’s 
autocomplete function lets you quickly and intelligently reuse entries from that list.   Increase your speed and 
consistency in indexing. Always have an overview of your index, which is not possible with Word’s native’s 
functions.    
 
Mark a range of pages for inclusion in your index…with ONE click. An immense speed saving over Word’s 
native functions in which this procedures takes nine steps, many clicks and keystrokes…and remembering bookmark 
names across different dialogues. 

Page list function to list all occurences of a given index entry and navigate amongst them , a function that is 
simply unavailable in Word.   

Search and replace functions for helping inspect and edit your index.  

Consolidate function for cleaning up your index, by combining scattered single page entries into one page 
range.  A great convenience and time saving for refining your index, a procedure that would be tedious with Word’ s 
native functions. 
 
Keeps cross reference entries organized and alphabetized. An organizational feature that helps you manage your 
index. 

Documentation Organization 
The “Getting Started: Overview” section contains instructions for installing IndexAssistant, and gives a general 
overview of indexing and working with Word.  

The “Getting Started: Working with IndexAssistant” section gives more detailed instructions for using 
IndexAssistant, and includes a quickstart guide.  This section should be all you need to get started with IA and begin 
familiarizing yourself with it. 

The “Reference” section gives complete, step by step instructions for all of IA’s functions, and also gives examples 
that will help you better understand how indexing works with IA and Word. This section also reveals all of IA’s 
powerful functions, so you should read it at least once.  

See the “Frequently Asked Questions & Troubleshooting” at the end for troubleshooting and some frequently asked 
questions. 

Documentation Conventions 
The abbreviation IA stands for IndexAssistant. 

In this documentation and in IA’s user interface, adding an index entry (field code) to your document is called 
marking your document.    

Names of buttons, tabs and text boxes in the user interface are enclosed in square brackets, e.g., click [Mark Single].  

Names of keys are enclosed in angle brackets, e.g., press the <F12> key. 

Menu items are separated by >, e.g., select Tools>IndexAssistant.  

File names are enclosed in double quotes, e.g., select “IndexAssistant.dot”. 



 4

Getting Started: Overview 

Installing 
1) To install IndexAssistant (IA), unzip the distribution file, or run the self-executing extractor program.  Save both 
“IndexAssistant Manual.doc” and “IndexAssistant.dot” (or “IndexAssistantDemo.dot” in the case of th e demo 
version) to a folder of your choice, e.g., C:\Program Files\IndexAssistant.  
 

Security note: If the attachment you received by email when you purchased IA has an extension other than 
.exe or .zip, your  security software (e.g. Norton AntiVirus or Zone Alarm) may have changed the extension 
from .exe to something else to protect you from viruses. In this case, change the file name so as to save the 
attachment as an .exe file. Then run it to unzip it.  

 
2) Important: Installation is done through Word macros contained in this document, and IA is programmed in 
Word’s macro language.  To install and run IA, you therefore need to set Word’s macro security settings to 
medium (Tools>Macro>Security in Word 2000 and higher; macro setting in Tools>Option in Word 97).  If your 
settings have not already been set to medium, then you will need to reopen this document before trying to use the 
install process below. And when you open this document, you need to tell Word to enable the macros in it.   
  

Note about Word macro security: On the medium security setting, Word will trust macros contained in your 
user templates or start up template directories, which is where IA will be installed. For all other documents 
Word will ask whether its macros should be enabled.  These are precautions against macro viruses. Do not 
install any Word documents that you do not trust in your user templates or start up template directories .  

 
3) Pick one of the two install options described in the columns below, and double click in one of the boxes in the 
bottom two rows to install either IA or the IA demo. If nothing happens when you double click, or you get a 
dialogue saying that macros are disabled, see the note in the paragraph above : 
 
 I) Install IA as a User template II) Install IA as a Startup template 

Availabity of IA:  If you install IA as a user template, to 
make it available for a document, you  
first have to attach your document to 
the IndexAssisant.dot (or 
IndexAssistantDemo.dot) template. 

If you install IA as a startup template, it is 
available for use with any document without 
any further steps. 

Which is the 
recommended option?: 

If you only occasionally index 
documents or are only indexing a few 
documents, this is the recommended 
option. 

If one of your main activities in Word is 
indexing, this is the recommended option. 

To install IA: Double click here Double click here  
To install the IA Demo: Double click here  Double click here  
 

Overview of IA Workflow 
The following outlines the general flow of working with IA. For detailed instructions see the “Getting Started: 
Overview” and “Reference” sections . 

1) Open a Word document that you want to index.  

2) Make sure that IA is available to the document. Load IA to start your indexing session.  

3) Mark your document for indexing using Word and IA: 

• Browse and navigate your document using cursor keys, mouse, etc. in Word.  
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• When you find text that you want to mark for your index, activate IA by pressing the IA key, <F12>.  Then 
use IA to mark entries as desired.  The IA key <F12> is your link to IA. 

• Or, activate IA to add cross reference entries to your index. 

• Repeats these steps as necessary.  

4) Build an index by using Word’s Insert>Index function to generate an index (usually at the end of your document). 
Or, update an existing index to reflect changes in your marking of the document, by placing Word’s cursor in an 
existing index, and pressing <F9>.   

5) Review the index generated in Word, and revise/edit it with Word and IA: 

• Activate IA to use its search, pagelist and navigation features to navigate and find index markings to revise.  

• Or, activate IA to consolidate existing index entries. 

6) End your indexing session by exiting IA. 

7) You can resume indexing your document at any time by return to step 1.  

Overview of Word’s Native Indexing Functions 
IA provides an intelligent and powerful interface for Word’s native indexing functions.  The following  gives an 
overview of the process of indexing in Word. If you are familiar with this process, scan this section anyway to 
familiarize yourself with the terminology used below.  
 
Building an index in Word is a two step process:  
 

1) Marking index entries, which means adding field codes, called index entries, that specify what pages to 
index under what headings, and what cross references to put in your index.  These field codes are visible 
only when Word is set to show hidden text (Tools>Options>View; IA automaticaly makes them visible). 

  
2) Inserting and generating an index, usually at the end your document.  

 
IndexAssistant greatly simplifies this process. It helps with step 1), marking index entries.   
 
There are three sorts of index entry fields you can add when marking index entries. The following briefly explains 
these fields.  (For more information, look in the Word help system under index; you may also want to acquaint 
yourself with using bookmarks in Word):  

a) Single index entries: Fields that tell Word to index a single page under a specific entry. E.g., the field { XE “Kant, 
Immanuel” } on page 23 tells Word to list, in your index, page 23 under the index entry “Kant, Immanuel”. You will 
end up with an entry in your index that looks like “Kant, Immanuel, 23” (of course there may be many other page 
numbers listed after your entry for Kant, but we’ll never put those in the examples in this document). 

b) Page range entries: Fields that tell Word to index a range of pages under a specific entry. E.g., if the bookmark 
“Kant” points to text on pages 30-35, then the field { XE “Kant, Immanuel” \r “Kant”} tells Word to list, in your 
index, page range 30-35 under the index entry “Kant, Immanuel”. You will end up with an entry that looks like 
“Kant, Immanuel, 30-35.”  

c) Cross reference entries: Fields that tell Word to cross reference one index entry to another. E.g., the field { XE 
“Greek philosophy” \t “See also Plato” } tells Word to put the cross reference “See also Plato” in the entry for 
“Greek philosophy”.  

IA helps you generate and manage all three sorts of index entry fields, and navigate to them.   

But you can also manually edit index entry field by editing the text within the field codes. NOTE: After manually 
editing entries in your document, press IA’s refresh button, so that IA’s list of index entries will correspond 
with those in your document. 



 6

AFTER MARKING YOUR DOCUMENT YOU WILL OF COURSE WANT TO GENERATE AN INDEX. TO DO THIS, GO TO 
THE END OF YOUR DOCUMENT, WHERE YOU WANT YOUR INDEX INSERTED, THEN CHOOSE INSERT>INDEX AND 
TABLES FROM THE WORD MENU. SEE THE WORD HELP FILE FOR MORE ON THIS FUNCTION.  

IA and Word Compatibility  
IA works by helping you use Word’s native indexing functions to mark a document. Documents marked by IA are 
fully compatible with Word’s native indexing functions: 

• Once you’ve marked a document with IA, you do not need to use or load IA to generate, update or print an 
index. 

• Someone who does not have IA but has Word can open a document marked by IA, work with it, revise 
index entries, update and print the index, etc. 

• Word documents that have are already marked for indexing in Word  are fully compatible with IA.  When 
IA is loaded or when you press the refresh button, IA reads in all the index entries in the document.  So you 
can take a document that someone else begun indexing in Word, and continue indexing it with IA. 

Getting Started: Working with IA 

Basic IA Operation: Loading; Activating & Marking Index Entries; 
Showing & Positioning; Exiting 
To work with IA: 

1.a) Make IA available in your document: Open the document that you want to index.  Make sure that 
IndexAssistant is available in your document. It’s available if there is a menu item Tools>IndexAssistant.  

Important Note: If you installed IndexAssistant as a User Template rather  than Startup Template, you will 
need to attach your document to the template to make it available.  Select Tools>Templates and Add -Ins; 
click [Attach]; select “IndexAssistant.dot”; press <Enter>; click [Ok].  

1.b) Load IA: Select Tools>IndexAssistant.  IA loads and displays itself.   

When IA is loaded, it sets your viewing options to show hidden text, so that you can see the index entry 
fields in your document; it turns off the AutoFormatting option for turning straight quotes to curly quotes, 
which makes it easier to manually work with index entry fields. Finally, it assigns <F12> to activate IA, 
and <F11> to the PopTo function. Viewing and Autoformatting options and key assignments are restored 
when you exit IA. 

2) Mark  your document and edit index entries: Do this by positioning your cursor where you want to add an entry, 
or by selecting a range of text that you want to mark. Then press the IA key, <F12>.  This activates IA, letting you 
use the features described below.  

3) Showing, hiding, and positioning IA: Clicking [Hide] hides IA without exiting it.  If you want IA to hide each 
time you mark your document, check the [AutoHide] box.  

In Word 2000 and after, IA floats over your document, so that you can shift back and forth between Word 
and IA without hiding IA.  In Word 2000 and after the best way to work with IA is shown in the last 
screenshot above: split your document in two panes (see “View two parts of a document simultaneously” in 
Word’s help system), and position IA in the upper half, so you can scroll the lower pane without IA 
obscuring it.  You can use the upper pane to look at your index or the list of your Xrefs. Unfortunately, 
Word 97 does not allow IA to float over a Word document, so when you load IA in Word 97, the 
[AutoHide] box is automatically checked, to let you get back to Word when you finish marking operations.  

4) Exit IA: Click the X shaped [Close] button in the top right hand corner of IA and click [Yes] to exit (if you click 
[No], IA will just hide). 
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Quickstart & Demonstration of IA’s Features : 
 
Tooltips 

Use IA’s tooltips to help learn the interface: leave your mouse over a control and a tip will appear with 
information about the control and its use.   

 
Add a single index entry, while maintaining an alphabetized list of all index entries in your document. This 
lets you quickly and intelligently reuse entries from the list of entries.   Increase your speed and consistency in 
indexing. Always have an overview of your index.  

Example: Click in the middle of the word “expression” and press <F12>.  IA activates, searches a dropdown list 
of all index entries in your document, and moves to the first one that begins with the word “expression.” Select 
from the dropdown list to easily see and apply index entries such as, “expression,” “expression:as movement,” 
“expression:gesture:temporality of.” (The colon indicates subheadings and sub-subheadings.)  Another 
dropdown list lets you see and select from these entries, plus any that contain “expression” as a subphrase (e.g., 
“habit:and expression).  Or, start typing an entry and IA autocompletes the entry from its stored list, so you 
don’t have to retype the whole thing.   

 
Mark a page range with ONE click. An immense speed saving over Word. 

Marking a range of pages in Word takes nine steps, many clicks and keystrokes…and you have to remember 
bookmark names across different dialogues.  In IA: Select a range of text, press <F12>, select an index entry 
from the dropdown list (or type a new one), and then click [Mark Range]. Done. IA automatically generates a 
bookmark name for your range based on your index entry (appending numbers if necessary to maintain 
uniqueness). It ensures that you don’t accidentally replace existing bookmarks (thus preventing you from 
messing up your index).  

Page list, and search and replace functions that help you inspect and edit your index.  

Example: Select an index entry, say “Kant,” from the dropdown list, click on the [Page List] tab, and click 
[Generate]. IA generates a list of all the pages and ranges marked with index entries for Kant. Click on a page 
number in the list to jump to the Kant index entry on that page. 

With one click, IA also lets you search up or down for: the text you had selected when you popped up IA; any 
index field; index fields containing the current index entry. Also fills and opens up the replace dialogue to let 
you change the text of index entry fields.  

Consolidate function for cleaning up your index.  A great convenience and time saving for refining your index.  

Often when you index single terms, you end up with multiple entries on contiguous pages, say an index that 
contains “Kant, 120, 121, 124.”  IA makes it easy to consolidate this to “Kant, 120 -24,” if that is what you want 
to do (the page list function helps with this decision).  With this example, select the text on pages 120 to 124, 
press <F12>, select “Kant,” and click [Consolidate]. Done. IA strips out all the single page index entries to Kant 
within your selected text, and marks the selected text as a range with the index entry “Kant.”  (Why not just 
directly edit the text of the index? If you do this you cannot use Word to regenerate your index, so you cannot 
stick with the fast index turnaround strategy, in which you repaginate your document according to your galleys, 
and then regenerate your index.)  

 
Add a cross refrence, keeping your cross reference entries organized and alphabetized.  

Example: Press <F12>, click the [XRef] tab, pick “See,” “See also,” etc. from a drop-down, and type in the 
entries that are being cross referenced (or use the drop down lists to pick them), then click [Mark XRef].  IA 
puts your cross reference entry fields in a region of your document that you pick, without moving from the text 
on which you are working.  If you want to edit your cross references, click a button, and IA takes you to an 
alphabetized list of all your cross references. Keeping all your cross references together and alphabetized makes 
it much easier to maintain and edit cross references.  

 
PopTo function 
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Position your cursor on a page number in your document index and press <F11>; IA pops you to that page so 
that you can see what your index is pointing to.  Or, position your cursor on the name of a bookmark in a index 
entry field, and press <F11>; IA selects the bookmark text, so you can see what range is being indexed.  

 

Reference 

A) Marking a Document with IA 
The following sub-sections focus on functions that help you mark your document, by adding new index entries to it. 
See (B) Navigating and Editing for functions that help you navigate your document and revise your marking.  

I) Marking a Single Page Entry 
1) Position Word’s cursor in the middle of a word you want to mark for your index, or select (highlight) a phrase 
that you want to mark. 

2) Activate IA by pressing <F12>. If Word’s cursor is in the middle of a word, IA will select it, and the word will be 
displayed in the [Selected Text] box. If you selected a phrase, that phrase will be displayed in the [Selected Text] 
box. The [Single] tab pops to the front (you can also manually select it). 

3) Specify the Index Entry. This specifies how Word is to index the selected text, letting you specify the entry, 
subentries or sub-subentries, etc., under which you want your selection to be indexed.  

E.g., if you mark the selected text “expression,” on page 5, with the index entry “expression,” it will be 
indexed under “expression”, and your index will contain “expression, 5”; if you mark it with the index 
entry “language,” it will be indexed under “language” and your index will contain “language, 5.”  
Subentries and sub-subentries are specifed by using a colon, e.g., if you mark the text “expression” with 
the index entry “habit:expression,”  your index will contain “habit,” with a subentry “expression, 5”.  
Important: no spaces before or after colons. 

You have three ways of specifying an Index Entry: 

a) Type in an entry. When you do this, IA autocompletes your entry with entries in the dropdown list, so 
you can quickly enter a long entry just by typing its initial letters.  

If  IA autocompletes your entry in a way you don’t like, highlight the unwanted text and press 
delete. Sometimes, depending on your list of entries, IA may put an intial capital on your entry 
that you don’t want; to fix this, after you’ve typed in your entry, highlight the capitalized le tter, 
and replace it with the lowercase.   

b) Pick an entry from the Index Entries dropdown. Do this by clicking on the dropdown arrow, scrolling 
through entries, and clicking on the entry that you want.  When you activate IA it automatically searches 
through the list to find the first entry that exactly matches the beginning of the selected text , so dropping 
down the list will show you possible entries that begin with the selected text.  (See the second screen shot: 
the list displays entries beginning with the selected text, “expression”.) 

c) Pick an entry from the Matches dropdown. Do this by clicking on the dropdown ellipsis (…), 
scrolling through and clicking on the entry that you want. The Matches dropdown list contains all entries 
that start with the selected text or contain the selected text as a subphrase . (See the third screen shot: the 
last item in the list is “habit:expression”, which contains the  selected text, “expression”.) 

Important tip re. keeping your index consistent: using the Index Entry list helps keep your index entries 
consistent, and lets you have a constant overview of the entries in your list.  Periodically check over the 
list: if it looks like there is a double entry in it, it is because there is a slight variation in the way you’ve  
typed in your entries, e.g., a space before or after a colon, an extra space at the end of the entry, etc.E.g., 
you might have entries for both “Kant ” and “Kant”.  You can use the navigation features of IA to quickly 
go to the index entry fields in your document and fix things up by editing the content of field codes in Word, 
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e.g., getting rid of a trailing space, changing “Kant ”  to “Kant”. If you click the refresh button and your 
double entry is removed from the drop down list, then you’ve fixed the pr oblem.  

4) If you want the page number for the entry to appear in bold or italic in the index, check the [Bold] or [Italic] 
boxes as appropriate. 

5) Click [Mark Single].  IA inserts an index entry field in your document immediately after the text you have 
selected, e.g. { XE “expression” }, or { XE “habit:expression” }.  

II) Marking all Occurrences of the Selected Text 
1) If you want to mark ALL occurrences of selected text with a given Index Entry, follow steps I.1-4. Then click the 
[Mark All] button.   

E.g., activate IA with “Kant” selected in your document, specify “Kant, Immanuel” as your Index Entry, 
then click [Mark All].  All occurrences of “Kant” in your document will be marked to be indexed under 
“Kant, Immanuel” (actually, only one occurrence of Kant per paragraph will be marked).  

N.B. For this function to work. you must have the text you want marked selected in the document, not just 
appearing in the selected text box.  

If you want to mark all occurrences of a list of names such as Kant, Plato, et c. you should consider 
building a concordance file and using Word’s native concordance function. Look in Word’s help file under 
concordances and automatically marking index entries by using a concordance file. This strategy, however, 
and use of IA’s mark all function might be counterproductive, since it might mark too many occurrences.    

III) Marking a Range of Pages 
The marking procedures above mark single pages for inclusion in the index, e.g. example marking the word “Kant” 
on page 20 under the heading “Kant,” so that your index contains “Kant, 20.”  What if you have a continuous 
discussion of Kant, from page 20 to 25? You want your index to show “Kant, 20-25”.  To do this you need to mark 
your text on pages 20-25 as a range. Here’s how (note that this takes a huge number of keystrokes and operations in 
Word, but IA makes it a cinch.):  

1) Select the range of text that you want to mark, e.g. a discussion of Kant on pages 20 to 25, as you would select 
any chunk of text in Word (by dragging from start to finish of the selected text, or by press <Shift> and using the 
arrow keys to select the text). 

2) Activate IA by pressing the <F12> key. The [Selected Text] box will display [Range] to indicate that you’ve 
selected a range of text.  The [Range] tab pops to the front (you can also manually select it).  

3) Specify the Index Entry, as per I.3.  

As you change the Index Entry, you will notice that the text in the [Bookmark for range] box changes.  IA is 
automatically generating a valid bookmark name that Word can use to mark the range (see note below). 
You can modify this if you like. 

4) If you want the page number for the entry to appear in bold or italic in the index, check the [Bold] or [Italic] 
boxes as appropriate. 

5) Click [Mark Range].   

IA bookmarks your range of text, and inserts an index entry field in your document immediately after the 
range, specifying how the range in your bookmark is to be indexed, e.g. { XE “Kant, Immanuel” \r 
“KantImmanuel”}.  

6) For use of the [Strip] and [Consolidate] functions, see, section VI below.  

Note: How IA handles “collisions” between bookmark names: 

If you marked pages 20-25 with the bookmark “KantImmanuel” and then marked page 41-50 with the 
bookmark “KantImmanuel” you’d ruin your index, because the second book mark woul d replace the first 
and you index would end up showing “Kant, 41-50” not “Kant, 20-25, 41-50,” as you wanted it to.   
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IA prevents this from happening by ensuring that bookmark names remain unique.  In our example, the 
second time you try to mark a range of text with the Index Entry “KantImmanuel”, Index Assistant tells you 
the bookmark name is not unique and ask whether you’d like to use “KantImmanuel2” instead.  It keeps on 
adding numbers to yield unique bookmark names. If you do want to use and thus repla ce an existing 
bookmark, tell IA you don’t want to use the substitute, and then disregard the warnings about replacing 
existing bookmarks. You can always, of course, modify bookmark names in [Bookmark for range] on your 
own, to specify your own unique bookmark names. IA will warnl you if your bookmark name collides with 
an existing one.  

(Note: if your bookmark names are very long, then the numbers added by IA won’t be enough to make them 
unique (this is a bad  behaviour of Word), and you’ll keep on getting  warnings that your bookmark name 
isn’t unique.  In this case you’ll have to manually adjust the bookmark name yourself.)  

III) Refreshing the Index Entries List 
If you’ve deleted index entry fields or manually edited them, you should click on the refresh button to regenerate the 
list of index entries, so that IA’s dropdown list of entries corresponds with what’s actually in your document. 

IV) Adding Cross References 
Cross reference index entries build bridges between entries in your index, e.g., letting you add an entry under “Kant, 
Immanuel” that specifes “See also German philosophy”, where “German philosophy” is another entry in your index. 

Important: Preparing your document for Cross References: To add cross references to your document with IA, you 
first of all need to specify where IA is to put cross reference index entry fields. It’s suggested that you put them at 
the end of your document, after your actual index.  Go to the very end of your document, making sure that your 
cursor is not inside the index that Word has generated (or inside the field code for the index; make field codes 
visible to check this); hit enter a few times to create a some blank lines; select the blank lines; select 
Insert>Bookmark, and add a bookmark with the name XRefList. As you add cross references, IA will put them in 
this bookmarked region. 

1) Activate IA by pressing the <F12> key. Select the [XRef] tab.  

2) Use the [See:] dropdown to select the kind of cross reference you want to add (See, See also, etc.), or type in your 
own custom text. In the example given above, this would be See also.  

3) In the [XRef Entry:] box, type the target entry of the cross reference. In the example given above, this would be 
“German philosophy”.  You can also select the target entry from the Index Entry dropdown (as per I.3), and then 
click [Paste IE], which copies the Index Entry into the [XRef Entry:] box. You’ll learn how to work with the [Paste 
IE] function in an efficient way. 

4) Specify the Index Entry, as per I.3.  In the example given above, this would be “Kant, Immanuel”.  

5) Click [Mark XRef].  In the example, this would add the field { XE “Kant, Immanuel” \t “See also German 
philosophy” } to the bookmarked region named XRefList.  You won’t see this happening on screen, as IA keeps the 
cursor in the text you are currently working on. 

6) To see your cross reference entries, click [Goto XRef]. This jumps your cursor to an alphabetized list of index 
entries. You can quickly fix cross references by directly editing the fields in this list. 

B) Navigating and Editing a Document with IA 
When you have finished marking your document, or as you mark it, you can take a look at the index generated by 
Word to get a sense of how your index is shaping up.  If you wish to revise your index, the functions documented in 
the following subsections help you navigate your document and revise index entries in it, thus changing your index. 
(See (A) Marking for functions that help you add index entries to your document.)  
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IV) Find Buttons:  
There are three sets of find buttons in IA. located in the double column of arrows along the top right side of IA (see 
Interface Screenshots). These buttons help you search for specific bits of text or index entries:. 

1) Finding the selected text: To find the next occurrence of the text in the [Selected Tex] box, click the right arrow 
in the first row of find buttons.  To find the previous occurrence, click the left arrow in the first row of find buttons. 
These buttons let you step through your document, looking for the selected text. 

2) Finding any index entry: To find the next index entry in your document, no matter its content, click the right 
arrow in the second row of find buttons.  To find the previous occurrence, click the left arrow in the second row of 
find buttons. These buttons let you step through your document, looking over index entries in it. 

3) Finding the current index entry: To find the current index entry (the one appearing in the [Index Entry] box, 
e.g. “Kant, Immanuel”), click the right arrow in the third row of find buttons.  To find the previous occurrence, click 
the left arrow in the third row of find buttons. These buttons let you step through your document, to check over 
instances of a particular index entry, e.g., all those pertaining to Kant. 

V) Page List: Reviewing and Editing your Index  
IA’s [Page List] function generates a list of all pages on which the current index entry appears, and lets you quickly 
navigate to each of those pages. You can use this function to help you remove excess entries, or to decide whether 
entries should be consolidated. 

1) Activate IA by pressing <F12>. Select the [Page List] tab.  

2) Select an existing Index Entry, as per I.3, e.g.,  “Kant, Immanuel”.  

3) Click on [Generate].  IA scans your document for the selected index entry, and lists all the pages on which it is 
found.  

4) Clicking on a page number jumps to the first instance of the selected index entry on that page.  

VI) Consolidating Index Entries 
Sometimes after you have marked your document and generated your index you will find an entry that contains too 
many references to contiguous pages, e.g., an entry “Kant, Immanuel” that contains something like the following list 
of page numbers: “2, 12, 13, 14, 15, 16, 110”.  On looking over pages 12 -16 you see that these pages in fact contain 
a continuous discussion of Kant, and it would be better if the entry referred to pages “1, 12-16, 110”.  So you need to 
convert single page index entries on pages 12, 13, 14, 15 and 16 to a range.  IA calls this conversion operation 
consolidating and lets you consolidate with a single click.  

1) Select the text that contains the single page index entries you wish to consolidate. In the example, this would be 
the text on pages 12 to 16 that contains the single page index entries for “Kant, Immanuel”. 

2) Activate IA by pressing <F12>. Select the [Range] tab.  

3) Select the Index Entry you want to consolidate, as per I.3. (In our example, this would be “Kant, Immanuel”. 
Selecting this entry will tell IA to strip out all single page index entries for “Kant, Immanuel” from the selected text 
and mark the selected text as a range to be indexed under “Kant, Immanuel”.) 

4) IA consolidates by using the mark range function. So make sure the [Bookmark for range] is appropriate (see 
III.3). 

5) Click the [Consolidate] button. IA asks you to confirm removal of all instances of the selected Index Entry within 
the selected text. When you confirm, IA strips out all these instances, and marks the range. (If there is a collision 
with the bookmark for the range, you will be prompted to help IA resolve the collision, see section III above.)  

6) You can also access the consolidate function from the [Page List] tab. If you consolidate from the [Page List] tab, 
you  won’t be able to see the bookmark being used for the range.  
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7) You can also use the [Strip] function on the [Range] tab to remove all instances of the selected Index Entry within 
the selected text, without marking the range.  

VII) Replace 
This functions launches Word’s replace dialogue, filled out to replace one index entry with another, e.g., to replace 
all instances of index entries for “German idealism” with “idealism:German”. 

1) Activate IA by pressing the F12 key. Select the [Replace] tab.  

2) Select the Index Entry you want to replace, as per I.3. In the example, this would be “German idealism”. 

3) Type the replacement index entry in the [Replace Index Entry with:] box. In the example, this would be 
“idealism:German”.  

4) Click the [Replace] button. This launches Word’s replace dialogue, filled out so as to do the replace you want.  

Be careful with this function: 1) this strategy for replacing fields works because the form XE “….” is not 
likely to occur in the text of your document, but if you do have this sort of text in your document, it will be 
replaced as well; 2) when Word replaces any part of a field, it seems to replace all of it, so when the first part 
of a cross reference or range field is changed using Word’s replace function, the rest of it gets obliterated (in 
the example { XE “German idealism” \t “See also Kant” } is replace with { XE “idealism:German” }.  A wiser 
procedure may be using the find buttons and manually fix things.   

VII) PopTo 
This is a helper function for doing lower level editing of index and field codes. Position your cursor on a page 
number or book mark name in your document (e.g., in the generated index or in a field code) and press <F11>. 
IndexAssistant pops you to the page or bookmarked text so that you can see what your is being pointing to.   

Frequently Asked Questions & Troubleshooting 
My manuscript is in WordPerfect or another word processor format, but I have Word. Can I use 
IndexAssistant for Indexing? 

Yes. Export your manuscript to Word or RTF and then open it in Word, or use Word’s filters to import 
your document. Then proceed with building your index. You can export the final index out of Word to send 
to your publisher, if needed. Remember that for the purposes of indexing, the import elements of your 
document are: text and pagination. So long as you can get your document into Word with the text on the 
same pages, and have your publisher work with an index contained in a Word document or exported into 
another format from Word, you can use Word and IndexAssistant to build your index for publication. 

I can’t open the attachment sent to me when I purchased IA.  

The attachment sent to you is a self-extracting archive containing IndexAssistant. Some security software 
such as ZoneAlarm of Norto Anti-Virus will change the extension of this file from .exe to something else, 
to protect you from running executable attachments by accident. If your security software has done this, 
change the extension back to exe. 

When I try to install IndexAssistant, nothing happens, or I get a message saying macros are disabled.  
 

IA is programmed in Word’s macro language.  To install and run IA, you need to set Word’s macro 
security settings to medium (Tools>Macro>Security in Word 2000 and higher; macro setting in 
Tools>Option in Word 97).  If your settings have not already been set to medium before installation, then 
you will need to reopen the manual before trying to use the install process, and when you open this 
document, you need to tell Word to enable the macros in it.  (Note about Word macro security: On the 
medium security setting, Word will trust macros contained in your user templates or start up template 
directories, which is where IA will be installed. For all other documents Word will ask whether its macros 
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should be enabled.  These are precautions against macro viruses. Do not install any Word documents 
that you do not trust in your user templates or start up template directories .) 

I don’t see IndexAssistant in the Tools menu in Word. 

Make sure you’ve installed IndexAssistant. Also make sure that IndexAssistant is available to your 
document. If you installed IndexAssistant as a User Template rather than Startup Template, you will need 
to attach your document to the template to make it available.  Select Tools>Templates and Add-Ins; click 
[Attach]; select “IndexAssistant.dot”; press <Enter>; click [Ok]. See the Getting Started section for more 
details.  

I was using IndexAssistant, and have now exited it.  But when I type quotes or apostrophes I get "" instead of 
“”. 

This can sometimes happen if your IndexAssistant session was not properly completed. To fix in Word: 
Tools>AutoCorrect>AutoFormat as You Type; turn on Straight Quotes with Smart Quotes. (IndexAssistant 
turns off this feature when it is loaded, to make it easier to manipulate XE field; it restores your original 
setting on exit, but an improper shutdown can interfere with this behaviour.) 

I was using IndexAssistant, and have now exited it.  But I am still seeing {XE} field codes. 

This can sometimes happen if your IndexAssistant session was not properly completed. To fix in Word: 
Tools>Options>View; uncheck the Hidden Text box. (IndexAssistant shows hidden text when it is loaded, 
to make it possible to manipulate XE field; it restores your original setting on exit, but an improper 
shutdown can interfere with this behaviour.) 

  

 


